Solución provisional para el lightbox de Blogger que no funciona | Oloblogger 02/04/2013 Problema solucionado. El que haya incluido este código ya puede retirarlo Desde hace uno...

23 de marzo de 2013

Solución provisional para el lightbox de Blogger que no funciona

02/04/2013 Problema solucionado. El que haya incluido este código ya puede retirarlo

Lightbox de Blogger
Desde hace unos días, no sé exactamente cuántos, el sistema de ventanas modales para imágenes (lightbox) que viene de serie con Blogger está fallando.

Como en el blog de problemas conocidos no decían nada y yo siempre estoy trasteando cosas, lo achaqué a haber borrado algo accidentalmente, pero tras tres comentarios de otros tantos amigos al respecto, ya se confirmó que la cosa era general.

Bien, pues parece que Soraya ha dado con el origen del problema y este es que el fichero JavaScript que se ocupa de esa tarea ha sido cambiado.

Eso es algo que carga Blogger directamente en nuestras plantillas y se conoce que han sacado una nueva versión, la han instalado y, como en otras ocasiones similares, no funciona como debería. De hecho esta vez es que no funciona nada. Esta historia quizás le suene a alguien...


Sabiendo esto la solución pasa por forzar que se cargue el fichero anterior y mientras lo sigan teniendo alojado en sus servidores no habrá el menor problema.

Para eso, se edita la plantilla y al final del todo, justo tras el cierre del body (</body>), tenéis que insertar esta línea

<script src='http://www.blogger.com/static/v1/jsbin/4235842921-lbx__es.js' type='text/javascript'/>

Y con eso el problema queda solucionado.


Como dato adicional, la versión que se está cargando actualmente con el conocido fallo es la 525304238-lbx__es.js. Con una página vuestra en el navegador, sólo tenéis que ver el código fuente de vuestro sitio y buscar "lbx__es.js". Con eso podréis comprobar qué versión se está cargando. Si el blog está en otro idioma distinto del español, el fichero llevará otro nombre, pero se puede cargar sin miedo el que dije, ya que sólo cambiará un palabra en la galería de miniaturas.

Importante

Como dice el título de la entrada esta es una solución provisional. Cuando tengamos constancia de que el nuevo vuelve a funcionar correctamente, lo mejor sería quitar esa línea que ahora hemos incluido. De esa manera tendremos las mejoras que -se supone- llevará ese nuevo lightbox.

Avisaré tan pronto me entere y os agradecería que me avisarais a mí si vosotros os dais cuenta antes.

¿Vemos otro post al azar por si le encuentras utilidad o quizás prefieres ser más metódico y suscribirte a nuestras entradas por correo? También puedes imprimir este artículo y por supuesto compartirlo en redes sociales si fue de tu agrado.

Compartir
Copy URL

Y muchos más artículos interesantes si nos sigues en...

follow us in feedly

113 comentarios :

  1. No me funciona el lightbox en el blog para ver las imagenes

    ResponderEliminar
    Respuestas
    1. Ejem... ¿Leiste el contenido de esta entrada?

      Eliminar
    2. Jeje... a mi tampoco me funciona después de leer la entrada ;)

      Eliminar
    3. ¿Lo pusiste tras el cierre del BODY? No lo veo en tu fuente.

      Eliminar
    4. En realidad no me ha funcionado nunca, supongo que choca con algún código :(
      Aún añadiendo tu línea sigue sin funcionar y tras probar la borré, de ahí que no la veas... seguiré desistiendo...
      Muchas gracias Oloman ;)

      Eliminar
    5. Entendido. Ese es otro misterio. Todavía no sé por qué en algunos sitios no funciona el lightbox de forma genérica. Esto es para aquellos a los que les funcionaba y desde hace unos días dejó de hacerlo.

      Eliminar
    6. hola oloman esta solucion provicional me fue muy util pero la buena noticia es que ya no es nesesaria por que google ya arreglo el problema el dia de hoy 2 de abril de el 2013 pero en fin el tip fue util mientras se nesesito de todas formas gracias oloman

      Eliminar
    7. Vale, como ya somos cuatro los que contestamos y todos afirmativamente, actualizo el post. Gracias ;)

      Eliminar
  2. Yeaaah!!! Funcionaa, en un primer momento cometí el error de pegarlo antes del body y pensé que no, pero si lo pegas después de la etiqueta (como se explica), solucionado.

    ¡¡Muchísimas gracias por el post!!

    ResponderEliminar
  3. Gracias por el código, funcionó.

    ResponderEliminar
  4. Si funciona, debe pegarse debajo del </body>

    ResponderEliminar
  5. gracias, pensé que yo había hecho algo que dejo de funcionar el lightbox, :)

    ResponderEliminar
  6. Excelente, ya me volvió a funcionar! Gracias!

    ResponderEliminar
  7. MUCHISIIIIMAAASSSS GRACIASSS!!!
    Lo he estado buscando durante 2 eternos dias

    ResponderEliminar
  8. Muchas gracias! Funcionando perfectamente

    ResponderEliminar
  9. Hola, tengo un problema, y necesito tu ayuda, espero que puedas ayudarme, el asunto se trata que en herramientas de webmaster, aparece que tengo todas las paginas con etiquetas duplicadas y me sale esto :

    TEMPLATE ERROR: No dictionary named: 'bog' in: ['blog', 'skin', 'view'] | datosparamujeres

    La verdad, no se que sera, si puedieras ayudarme, te lo agradeceria mucho. Este es mi blog

    http://datosparamujeres.blogspot.com

    ResponderEliminar
    Respuestas
    1. ¿Me puedes decir en qué apartado exacto de Webmasters Tools te da esos dos resultados? El segundo tiene pinta de que en algún sitio pusiste "bog" en lugar de "blog" en tu plantilla.

      Eliminar
  10. Disculpas por mi ignorancia, pero voy a editar plantillas (¿se hace en "editar HTML?) y al final no me aparece la famosa palabrita "body". ¿Dónde está?
    Muchas gracias por la ayuda.
    Abrazos!
    http://juanhracingteam.blogspot.com.ar/

    ResponderEliminar
    Respuestas
    1. Entra en diseño/plantilla/editarHTML/busca uno que empieza así: script type='text/javascript'> es corto y al final aparece el body a continuación lo pegas.

      Eliminar
    2. ¡Muchas gracias José Luis!
      Probé y... funcionó!
      Abrazos!

      Eliminar
  11. Creía que había sido yo el que había "roto" algo. Cuando he visto que en el blog de un amigo tampoco funcionaba el lightbox he supuesto que el problema era de blogger. Muchas gracias por la solución.

    ResponderEliminar
  12. Solucionado lo del Lightbox, Muchas gracias!

    ResponderEliminar
  13. Gracias por la solución, el lightbox por fin funciona.

    Salu2

    ResponderEliminar
  14. Muchas gracias Oloman, estás en todo,
    saludos.

    ResponderEliminar
  15. ¡Aleluya! Gracias mil... no sabes cuánto me irritaba que sucediera esto...

    ResponderEliminar
  16. Amigos, probé agregando la línea y se solucionó el problema.
    Propongo que nos mantengamos en contacto mediante esta entrada, así cuando se solucione el problema general, sepamos que es el momento de retirar la línea.
    ¡Muchas gracias!
    Abrazos!
    http://juanhracingteam.blogspot.com.ar/

    ResponderEliminar
    Respuestas
    1. Yo voy probando todos los días en otro blog en el que no añadí el código, pero si os enteráis antes pues estupendo. Alguien me dijo hoy que se había arreglado, pero lo cierto es que a mí me sigue fallando en ese otro blog.

      Eliminar
    2. Muchas gracias Oloman por la ayuda que nos das; también yo estoy probando diariamente en otros blog, y hasta el momento veo que el problema persiste.
      Ni bien note algún cambio aviso aquí.
      Abrazos!

      Eliminar
  17. Funciona! Muchísimas gracias!!

    ResponderEliminar
  18. a mi no me funciona, lo puse al lado y tambien debajo y no me funciana, algo debo estar haciendo mal. Voy a tener que esperar a que se solucione. muchas gracias de todas maneras, al menos ya se que es un problema del lightbox que en algun momento pasara.
    saludos!

    ResponderEliminar
    Respuestas
    1. ya esta! ahora si me funciona perfecto! era un error mio. muchas gracias!! =)

      Eliminar
  19. no meu não funciona, já coloquei abaixo da tag e acima e mesmo assim ainda não funciona, frustado!.

    ResponderEliminar
    Respuestas
    1. só pra dar um feedback , funcionou aqui também.

      Eliminar
    2. Se fosse androidgameshvga, eu vi isso funciona. Obrigado

      Eliminar
  20. Muchas Gracias!!! Me funcionó al Instante. http://www.micordobaargentina.com.ar/

    ResponderEliminar
  21. Como es de costumbre, una solución genial que funciona a la perfección, comprobado!
    Solo añadir un punto. Como tu bien dices, la versión que se está cargando actualmente es la 525304238-lbx__es.js. Sin embargo, y hablo solo de mi caso, no tengo instalada dicha versión sino esta otra (3659615306-lbx__es.js) y tampoco se visualizaban las imágenes, hasta que e instalado el "script" sin problemas. "Lo me da que funciona con todas las versiones". Muchas gracias "Oloman " www.promodecor.com

    ResponderEliminar
    Respuestas
    1. Puede haber varias versiones que funcionen porque también vi que según el idioma del usuario, el fichero cambia. Supongo que el quid está en localizar la versión anterior a la actual y usar ese.

      Eliminar
    2. Gracias de nuevo un detalle añadido muy interesante

      Eliminar
  22. Muchas gracias por tu ayuda! Puse el script y funciona de maravilla :)
    Saludos

    ResponderEliminar
  23. Hola Oloman coloqué la linea detrás del cierre (/body) pero aun sigue sin funcionarme el lightbox, creo que debo esperar a que blogger solucione el problema, aun así muchas gracias!

    http://solomacosx.blogspot.com/

    ResponderEliminar
    Respuestas
    1. Hoy lo veo antes de ese cierre y no después. Prueba a ponerlo antes de </html> para no fallar.

      Eliminar
  24. he estado esperando unos días pero como no se soluciona el problema, al final he editado la plantilla y funciona perfecto
    gracias oloman oloman

    ResponderEliminar
  25. Oloman ,muchas gracias SI funciona.

    ResponderEliminar
  26. gracias, pensaba que había "roto" mi plantilla o algo

    ResponderEliminar
  27. Muchas muchas muchas gracias, me estaba volviendo loco, como tu , yo pensé que había borrado algo de la plantilla, me ha sido de gran utilidad, estaré atento a tu blog para ver si lo solucionan.

    Un Abrazo.

    mi blog: www.FountainPenLand.tk

    ResponderEliminar
  28. gracias mil por esta solución! en serio, cada vez que tocan algo nos joden la pantilla a todos! menudos chapuceros son estos de google con Blogger, deberían cuidarnos más o al final nos iremos todos a Wordpress.

    ResponderEliminar
  29. Ya está corregido el problema de blogger

    ResponderEliminar
    Respuestas
    1. Eso parece. Al menos a mí me funciona en otro blog en el que no puse esto.

      Gracia por avisar Roberto :)

      Eliminar
    2. Este comentario ha sido eliminado por el autor.

      Eliminar
    3. ¿Qué hacemos ahora? ¿Sacamos la línea que insertamos y lo dejamos como estaba antes?
      Abrazos!

      Eliminar
    4. Sí, con eso es suficiente Juanh.

      Eliminar
  30. Pues a mi a día de hoy me seguía sin funcionar teniendo activado el lightbox. Yo pensaba que había instalado algo y había dado conflicto. Es lo único que leía. Hasta que hoy veo tu entrada por casualidad. Pensaba que todavía no estaba arreglado para nadie hasta que leí vuestros comentarios anteriores. :S Así que a mi no me ha llegado el arreglo?? me toca seguir usando el arreglo temporal...que he añadido hoy. A ver si pronto se arregla. Saludos y gracias!!!

    ResponderEliminar
    Respuestas
    1. Según me han contado muchos, ya está solucionado. El problema tuyo probablemente es la plantilla, en la cual seguramente no te funcionaba tampoco antes de esta "avería".

      Si es así en el comentario 38 tienes una posible solución.

      Eliminar
    2. No puedo decirte cuanto llevo así. Lo descubrí un día que me dío por pinchar en una foto. Yo daba por sentado que funcionaba bien como otras veces.

      Pues será cosa mía y como no se de donde viene el fallo tendré que tirar de este arreglo...Y Si,lo intenté, pero no aparece lo que comentais en mi plantilla (expandiendo la plantilla de artilugios) y por eso no puedo cambiarlo. Lo mío vendrá de otro lado...quien sabe.. mi conocimiento en ésto es muy bajo. Pero voy aprendiendo cosillas leyendo tu blog :)

      Gracias de todas formas

      Eliminar
    3. Gracias por nada, porque ahora mismo te está funcionando ;)

      Eliminar
    4. Hola. Hoy por curiosidad quite este arreglo para ver si ya me funcionaba el lightbox... Y ya va bien!! No he tocado nada en esa parte despues que puse tu arreglo provisional.... Así que imagino que no sería cosa mía al final :D

      Eliminar
    5. Pues va a ser que no ;)

      Eliminar
  31. Verás cambié de plantilla y no funciona ni con el script, ni sin el script, y si lo tengo activado en las configuraciones, alguna idea!!!

    ResponderEliminar
  32. Perdona por ser tan pesado, pero ya lo solucioné, por si a alguien le sirve en mi plantilla cambié este código.

    <div class='entry'>

    por este otro:

    <div class='post-body entry'>

    y listo, no es cosa mía, lo vi en ciudad blogger.

    Saludos.

    ResponderEliminar
    Respuestas
    1. Estupendo, porque nunca he sabido qué es lo que originaba el problema. Se ve que ese post de Potro me lo salté ;)

      Gracias

      Eliminar
  33. hola, gracias por avisar lo del lightbox, ya funciona
    pero tengo otra pregunta,es si puedo hacer un enlace a una entrada en una imagen y que se vean todas en lightbox
    es decir, tengo una entrada y veo solo una imagen, clico y se va a la entrada completa, clico otra vez y veo todas las imágenes de la entrada con lightbox incluyendo esta primera
    es posible

    ResponderEliminar
    Respuestas
    1. No entiendo lo que ocurre y lo que debería ocurrir ¿me pasas el enlace a una de esas entradas y me lo intentas explicar de nuevo?

      Eliminar
    2. siento no haberme explicado bien
      lo que quiero decir es que quiero hacer como es este blog http://hicarquitectura.com/
      donde para cada entrada hay una imagen principal, tu la clicas y se redirige a todo el contenido de dicha entrada.
      y allí puedes ver todas las imágenes con lightbox.
      no se si me he explicado ahora
      muchas gracias

      Eliminar
    3. Bien, lo primero es hacer un sistema de "sumarios" (buscando a la izquierda en la barra lateral te salen varios sistemas) para que en portada aparezca una imagen y un resumen de texto.

      Luego el lightbox de Blogger hará el resto y si no te funciona pues ya aplicas esto de este post y en última instancia, lo del comentario #38

      Eliminar
    4. no he podido verlo hasta ahora, pero intentare hacer lo que dices
      gracias

      Eliminar
  34. Hola Oloman, Que tal estas?> Me ha servido muchisimo el comentario numero 38. Ya pensaba que en mi plantilla no se podia y gracias a tu website lo he podido arreglar. Simplemente me gustaria preguntarte algo. Mi blog es fundamentalmente de viajes y pongo muchas fotos. A veces uso fotos de google y las uso en mi blog. Parece que el light box no reconoce esas fotos sacadas de google, ya que no salen en la secuencia. Sabes si existe alguna forma de habiltar tambien esas fotos para que salgan junto con las mías.. Un saludo y muchísimas gracias por tu blog.. Jose xxx.
    (www.dondeandaras.blogspot.com).

    ResponderEliminar
    Respuestas
    1. No, no conozco ninguna forma. Por lo que yo sé el lightbox sólo carga las que hayas subido desde el propio Blogger y seguramente desde Picasa y Google+. Puedes buscar si hay alguna solución, pero personalmente pienso que no la hay.

      Eliminar
  35. Hola Oloman , tengo un serio problema ,hace ya muchos días intento entrar en bloguer y cual es la sorpresa ,no puedo acceder al diseño ni a ver los comentarios para publicarlos ,esto significa no poder anunciar nada al lado derecho del blog de nuestra asociación cultural, ojala puedas ayudarnos .

    ResponderEliminar
    Respuestas
    1. Eso suena a que ya no eres administrador y que tu usuario está sólo como editor. Tendrás que ver si queda alguien más (o quizás otra cuenta tuya) que esté como administrador y pueda volver a habilitarte.

      Eliminar
  36. Hola Oloman
    A mí me funciona el lightbox pero sólo cuando uso el editor del blog.
    El problema es que me gusta usar WLW (Windows Live Writer)y allí no me da la opción de añadir el efecto, a pesar de que se supone que debería dar esa opción en las opciones de link de imágenes
    ¿Tienes alguna solución para que el lightbox de Blogger se detecte en WLW?
    Muchísimas gracias

    ResponderEliminar
    Respuestas
    1. No conozco todos los servicios y herramientas que existen y esa es una de ellas. De todas formas lo único que necesita el lightbox de Blogger es que la imagen incluya un enlace a la imagen a tamaño original (s1600).

      Eliminar
  37. Gracias Oloman
    Pero ya incluyo el enlace a imagen tamaño original...y no funciona.
    Me gustaría hacerlo a mano.
    Como vi una entrada tuya en la que indicabas a otro "preguntón" que quería quitar el efecto que sólo tenía que borrar el código que rodea la URL de la imagen... (del tipo DIV...)Pues, había pensado invertir el proceso...
    Pero, soy incapaz de encontrar tu respuesta ya que no recuero el título de la entrada y las que me salen con el buscador de tu web, ninguna es la que necesito.
    Por favor, ¿recuerdas a qué me refiero?
    Muchísimas gracias

    ResponderEliminar
    Respuestas
    1. Ahora sí que no entiendo nada. He ido a tu blog, he pinchado en el plano bajo la frase "El Saloncito, situado en la Calle Ramiro El Monje, 9 de Huesca" y el lightbox funciona. Si en alguna imagen concreta no te funciona, sólo fíjate en cómo está el código de esa y listo.

      Eliminar
  38. Disculpa Olomán...
    Es lo que te decía: Si subo con WLW no funciona, pero sí desde el editor de Blogger, por lo que ahora no hay ninguna imagen subida con WLW.
    La cosa es que, subiendo desde el propio Blogger me resulta mucho más difícil cuadrar varias imágenes y texto a mi gusto...(a pesar de las opciones de imágenes de Blogger que se quedan cortas)
    Es por eso que te preguntaba alguna solución...
    He mirado entre otros sitios en
    http://answers.microsoft.com/en-us/windowslive/forum/writer-sharing/picture-dont-open-in-light-box-when-i-use-windows/dd320ac3-092d-47ee-af4a-b7f2ff4f6f6c?page=2&msgId=1e789bf1-09fb-41f4-a773-67b4cf6bff0c
    pero nadie da solución

    ResponderEliminar
    Respuestas
    1. Como te dije al principio no conozco nada de Windows Live Writer, así que no te puedo ayudar con ese editor. Lo único nuevo que no te he dicho y que se me ocurre ahora es que pegues el código de WLW, luego subas la misma imagen a Blogger y que por último tomes la dirección de enlace y de imagen de Blogger y la pases al código de WLW, borrando por último el código que generó Blogger.

      Es posible -sólo posible- que el Lightbox funcione sólo con imágenes de Blogger (Picasa) pues estas son siempre ampliables y reducibles (ver esta entrada).

      Eliminar
  39. Hola Oloman, tengo un problema, antes de cambiar de plantilla funcionaba el lightbox, pero al cambiar, dejo de funcionar, espere unos días pensando que se arreglaría y no es asi, coloque la linea del script como indicas en este post, pero no funciona, a pesar de tenerlo activado, por favor ayúdame, te lo agradecería mucho, mi blog es http://blog.rafomorales.com/

    ResponderEliminar
    Respuestas
    1. Hola Rafael. Prueba con el penúltimo truquillo de los que encontrarás en este post.

      Eliminar
    2. Oloman, gracias por el dato, pero en mi plantilla no tengo esa linea de código, y no se donde colocarlo, me podrias ayudar gracias...

      Eliminar
    3. ¿Es Blogger? Es que no encuentro tu blog en tu perfil

      Eliminar
    4. Si claro si es blogger, mi blog es http://blog.rafomorales.com/

      Eliminar
    5. Tienes una caja que es div class='post'. Quizás si añades ahí y dejas div class='post post-body entry' funcione, pero no lo sé seguro porque tienes una plantilla de las del nuevo diseñador y ya es notorio la manía que le tengo a esas. De todas formas también he visto que tienes un truco para añadir el botón pin a todas las imágenes y es posible que eso te esté interfiriendo. Prueba también a quitarlo provisionalmente a ver si te funciona sin el Pin It.

      Eliminar
  40. ¡Por favor necesito tu ayuda!
    Tengo el siguiente blog: http://mondejarfoto.blogspot.com.es/
    Siempre me ha funcionado Lightbox de Blogger, pero no se por que motivo, en las dos últimas entradas no funciona, mientras que en anteriores si. ¡NO LO ENTIENDO! He mirado que en Picasa esté todo bien, y las imágenes de las dos últimas publicaciones tienen las mismas propiedades que el resto, no cambio nada. La función Lightbox está activada... ¡NO SE QUE HACER...!

    AQUÍ NO FUNCIONA: http://mondejarfoto.blogspot.com.es/2014/08/tres-toreros-que-vencieron-la-lluvia.html

    AQUÍ SI FUNCIONA: http://mondejarfoto.blogspot.com.es/2014/08/el-arte-del-toreo-en-jose-luis-galloso.html

    GRACIAS, GRACIAS, GRACIAS...
    Saludos y no dejes nunca de guiarnos...

    ResponderEliminar
    Respuestas
    1. Pues no lo sé Jose María, entre otras cosas porque ando con una conexión móvil de las más lentas y tras tres minutos esperando para que se cargara una de esas páginas, tuve que abandonar y ya ni lo intenté para la segunda.

      Pero lo que está más o menos claro si en unas páginas te funciona y en otras no, es que tienes algo diferente en ellas. Publica una entrada de prueba (con fecha antigua para que no se vea mucho) sólo con la mitad del contenido del post que no te funciona y observa si sigue pasando. Si ya funciona el lighbox, ya sabes que en la mitad que no copiaste es dónde está el problema y viceversa. Luego repite la operación con la mitad que hace que no funcione y así vas acortando sucesivamente las posibilidades hasta saber qué cosa exacta es la que te está interfiriendo.

      Eliminar
    2. Hola de nuevo Oloman. Antes de nada un millón de gracias por contestar, eres la única persona que lo ha hecho hasta ahora.
      Después de mucho mirar y comparar líneas de código de las entradas donde funcionaba todo bien y donde no, he encontrado algo que al parecer es por lo que las fotos no aparecen en el lightbox de Blogger y se abren en la ventana. Yo la forma de publicar no la he cambiado, sigo haciendo todo igual, pero no sé por qué ocurre esto.
      En la imagen que te enlazo (https://dl.dropboxusercontent.com/u/83360597/FALLO%20BLOG%202.jpg) se puede ver que en las tres primeras (marcadas con Funciona) el enlace hacia la imagen en "href" es igual que en "scr" (los he cambiado yo manualmente). Mientras que en la cuarta (marcada con No Funciona) cambian estos datos (es como aparecen cuando redacto y miro en HTML).
      ¿Se te ocurre a que puede ser debido?
      He solicitado ayuda e Blogger y en el foro de google, pero no contesta nadie.
      Necesito ayuda, por favor.
      Muchas gracias de nuevo y un saludo.

      Eliminar
    3. Evidentemente, la que no funciona es porque su dirección de destino para lightbox (la del HREF) no guarda ninguna relación con la imagen en sí (la del SRC). Prueba simplemente a copiar la direccion que termina en (105).jpg y a ponerla en lugar de la que acaba en 29.jpg, todo dentro del trozo que marcas como No funciona.

      Si eso no soluciona el problema, borra ese trozo que no funciona, desde su DIV CLASS="SEPARATOR" hasta su correspondiente cierre /DIV, ambos inclusive y luego sube de nuevo la imagen al post.

      Eliminar
    4. Gracias Oloman, eso es lo que he tenido que hacer al final en el post de hoy, copiar las direcciones de las imágenes a mano ¡Más trabajo!

      No se si esto será fallo de Blogger o mío, pero me hace polvo y estos de blogger no contestan...

      En fin, gracias por tu ayuda y un saludo.

      Eliminar
  41. Una cuestión Oloman, ¿Hay algún otro modo de mostrar las imágenes similar al Lightbox aunque sea de terceros y con calidad? Tengo que subir muchas fotos durante estos días y me da miedo si lo tengo que hacer a mano. Gracias.

    ResponderEliminar
    Respuestas
    1. No creo que lo tengas que hacer a mano, porque eso de que haya dos imágenes con distinta dirección no es normal. Probablemente las cambiaste accidentalmente.
      De todas formas hay muchos programas. Particularmente me gusta Lytebox.

      Eliminar
  42. Pues vaya, estamos en las mismas, parece que a Blogger se le ha vuelto a ir la pinza con el Lightbox... desde ayer, ninguna entrada nueva funciona correctamente, las imágenes se abren a su tamaño original en una ventana y para volver al blog hay que darle al botón de "atrás" He probado a poner ese código y nada, no funciona, y lo he puesto en el sitio correcto... ainsss que desesperación... ¿alguna solución? Mil gracias.

    ResponderEliminar
    Respuestas
    1. Estamos en las mismas! Creí que era cosa mía...

      Eliminar
  43. Hola. Echad ambos un vistazo al post que publiqué ayer, que creo que va a ser eso.

    ResponderEliminar
  44. Hola, a mi tampoco me funciona :(

    ResponderEliminar
    Respuestas
    1. Dos posibles problemas, dos posibles soluciones:
      http://www.oloblogger.com/2014/11/blogger-imagenes-sumarios-que-no-aparecen.html
      http://www.oloblogger.com/2013/06/problemas-blogger-soluciones.html (último apartado)

      Eliminar
  45. Saludos.
    Estoy comenzando mi nuevo blog & la verdad no me funciona el Lightbox, intente tu linea pero no nada, intente buscar la del comentario 38 & no me sale por ningún lado, entonces a esta época no se que hacer & en mi blog subiré muchas entradas con muchas imágenes, auxilio u.u

    ResponderEliminar
    Respuestas
    1. De nuevo por acá molestando, estoy subiendo algunas imagines a una pagina estática en mi blog & estas no aparecen en lightbox, en las entradas si funciona ahora pero necesito ayuda con el lightbox de las paginas.

      Eliminar
    2. Vivienne, ve al comentario de más abajo y sigue el enlace que le puse a Miguel. Quizás eso te sirva.

      Eliminar
  46. amigo muy bueno tu blog, de verdad me has ayudado mucho, ahora necesito tu ayuda para que me digas como volver a poner el lightbox en blogger, yo use una plantilla y la plantilla no tiene lightbox.... ya he hecho de todo y nada, espero me ayudes por favor :(

    ResponderEliminar
    Respuestas
    1. Hola Miguel. A ver si te sirve una solución que publiqué en esta entrada. Está en penúltimo lugar. Saludos.

      Eliminar
  47. Hola de nuevo Oloman.
    Necesito ayuda, ha dejado de funcionar mi lightbox en blogger.
    ¿Sabrias decirme que le pasa?
    www.mondejarfoto.es

    ResponderEliminar
    Respuestas
    1. Hola. Echa un vistazo al final de este post por si con eso que indico ahí se soluciona el problema. De lo contrario, no conozco otro arreglo.

      Eliminar
  48. Hola Oloman, gracias por contestar, precisamente tenia en mente mandarte un mensaje, puesto que al final se ha solucionado, y todo gracias al Foro de ayuda de Blogger, donde se que tu también colaboras.
    Te dejo el enlace para que veas como se ha solucionado, por si en un futuro te puede servir.
    https://productforums.google.com/forum/?utm_medium=email&utm_source=footer#!msg/blogger-es/PfRP9iJqWPs/1dzXfsNHAgAJ
    Muchas gracias de todos modos y saludos.

    ResponderEliminar
  49. Buenas noches Olo, decidi cambiar de plantilla & estoy teniendo problemas con el lightbox, primero fue con el estilo de la galeria, ahora es con el lightbox que no quiere acomodar de ninguna manera, mejor dicho, dale una mirada a una de mis entradas & veras a lo que me refiero, por fa ayuda....

    http://www.viviennecrosse.com/2016/06/v-part-white-fire-religion.html

    ResponderEliminar
    Respuestas
    1. Pues no sé a qué te refieres. Cuando pincho en alguna yo veo las imágenes en formato galería sin problemas.

      Eliminar
    2. No se veía porque cambie a la plantilla que tenia antes, pero ya volví a poner la plantilla & el primer código de
      div class='entry' no sale en ningún lado en esa plantilla, solo salen div class='post-body' & div class='post-body entry-content' expr:id='"post-body-" + data:post.id' itemprop='articleBody'. traté de cambiar esos dos a div class='post-body entry' pero no funcionó.

      Antes cuando tenia esa plantilla no recuerdo que fue lo que edite, cuando se abría una imagen, aparecía detrás del cuerpo de la entrada & no se podía ver bien.

      Ahora ni asi funciona, por fa, ayuda, dejare la plantilla hasta que la mires.

      Gracias.

      Eliminar
    3. Vivienne, tienes al menos un par de div class='post-body'. Prueba a añadir la clase entry en ambos.

      Eliminar
    4. No salen, la chica que hizo el tema me dice que elimino la opción de light box porque blogger estaba poniendo problema algo así, entonces no sale ni ese código de div class='post-body' por eso tengo ese lio.

      Eliminar
    5. Entonces no sé cómo restaurar todo el código Vivienne. Si han eliminado el código del lightbox de Blogger y además las clases de las cajas son también distintas, no puedo ayudarte.

      Eliminar